Unable to access Enom account

A couple of my domain names registered with EnomCentral.com are expiring soon, so I thought I better transfer them to Go Daddy while I can (Go Daddy being cheaper than EnomCentral). I logged onto my EnomCentral account to unlock the domains and retrieve the authorization/EPP code. However, when the familiar EnomCentral dashboard appeared, it “ERROR – Account not found in database.”

I thought it was weird so I clicked the Domains > My Domains link to check if my domains were okay. I got the following message:

Bad User name or Password
Failed to get site processor. Please try again.


Bad User name or Password - 3
Loading results

No results returned by query.

I was afraid someone hacked into my account. I decided to call Enom, even though I knew it wasn’t going to be toll-free (I don’t live in the US). Calling Enom Support requires your personal identification number (PIN), which can be found on your Enom Account Info page. When the answering machine prompted me for my PIN, I entered it. What do you know? The phone system didn’t recognize it.

I had no other choice but to settle for the slower alternative — I fired off a support ticket. After an hour or so, I received a reply from one of their support guys:

Any customer that has a symbol in their password appears to get the error message while logging in. Please try resetting your account password to not include any symbol.

That symbol is my password may be the only reason that’s preventing my account from being hacked. Now Enom wants me to change my password to something less secure? It didn’t sound like I had a choice, so I tried resetting my password. Guess what? The system couldn’t reset my password because it couldn’t find my account on its database.

This is starting to sound like the chicken-or-egg causality dilemma. So I fired off another support ticket. I’m still waiting for a reply.

Is anyone else experiencing this issue?

  • Adam Cady

    Hello,

    I had the exact same issue and I was able to trace it down to a blank space.

    In my case I have a number of passwords that I use to login to Enom and I was cutting and pasting the password into the password box and I had an extra blank space on the end.

    For whatever reason Enom ignores the space and logs you in, but gives those errors after.

    Not sure if you are experiencing the same issue.

  • admin

    @Adam: Thanks for chiming in. Yes, the issue I encountered is similar to yours. I got confused by Enom’s initial response; I thought they wanted to ‘reset’ my password. It turns out I only need to change my password to one that does not contain any symbols. It solved my problem.

  • Shankolij

    Tried to access my account. Having forgotten myPW I requested it. Response: “Check your e-mail”. I go to my e-mail but there is no e-mail from them!! Tried several times. No luck. I know I did not have any symbols in my password though.